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Advanced
Tutorial Versioning

This Advanced Tutorial explains how to use the Versioning Task Processor to 
create jobs which contain several different versions, and to choose the optimal 
set of plates to be made. The main purpose is to generate accurate proofs of the 
different plate versions before assembly and output.

Duration: You will need 
approximately 5 hours to 
complete the lessons in 
this Advanced Tutorial.
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This tutorial is only a preview of the full advanced tutorial.

If you would like to obtain the full version of this tutorial or
a training on this subject, please contact your local Agfa sales

or service representative.
Worldwide addresses of our local Agfa representatives can

be found on our Agfa Graphics website:
http://www.agfagraphics.com/global/en/maings/about_us/

worldwide/index.jsp
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Advanced Tutorial Objectives

This Advanced Tutorial is divided into a series of lessons. In these lessons, you 
will learn how to:

Create a basic versioning job using a set of input files which contain images 
(common for all versions) and specific version data (which differs for each 
individual version).

Produce a versioning job which uses automatic page placement. The job will 
contain 3 flows: a Main flow, an imposition proofing flow and a page 
proofing flow.

Create a versioning job where images and version-specific files are delivered 
separately. The job will include language versions and currency versions, 
resulting in 7 printable versions.

Create a versioning job from a PDF with layered content. The PDF file 
contains a default layer (common data) and 3 version-specific layers: 
English, French and German.

Create a versioning job from multiple PDFs where version-specific data is 
printed on a 5th plate.

Create a 16-page job in three languages: English, French and German. 
However, the address on page 16 of the job will be different for the various 
countries in a language group. 



Sample

2 ADVANCED TUTORIAL OBJECTIVES

:APOGEE PREPRESS: Advanced Tutorial doc. version: 6.0.4

Advanced Tutorial Objectives

This Advanced Tutorial is divided into a series of lessons. In these lessons, you 
will learn how to:

Create a basic versioning job using a set of input files which contain images 
(common for all versions) and specific version data (which differs for each 
individual version).

Produce a versioning job which uses automatic page placement. The job will 
contain 3 flows: a Main flow, an imposition proofing flow and a page 
proofing flow.

Create a versioning job where images and version-specific files are delivered 
separately. The job will include language versions and currency versions, 
resulting in 7 printable versions.

Create a versioning job from a PDF with layered content. The PDF file 
contains a default layer (common data) and 3 version-specific layers: 
English, French and German.

Create a versioning job from multiple PDFs where version-specific data is 
printed on a 5th plate.

Create a 16-page job in three languages: English, French and German. 
However, the address on page 16 of the job will be different for the various 
countries in a language group. 

 

 VERSIONING 3

doc. version: 6.0.4 :APOGEE PREPRESS: Advanced Tutorial

Before You Begin

Before you start the lessons in this Advanced Tutorial, make sure that you are 
logged on to the :APOGEE Prepress System with Administrator access level.

You will also need the following sample files and tickets which are bundled 
together with this Advanced Tutorial PDF file:

Job Tickets

studentname-versioning-0001.ajt

studentname-versioning-0002.ajt

studentname-versioning-0003.ajt

studentname-versioning-0004.ajt

studentname-versioning-0005.ajt

studentname-versioning-0006.ajt

Sample PDF Files

ApogeeX Brochure_VEng_P1-16 cmyk only.pdf

ApogeeX Brochure_VFr_P1-16 cmyk only.pdf

ApogeeX Brochure_VGer_P1-16 cmyk only.pdf

ApogeeX Brochure_VImages_P1-16.pdf

ApogeeX Brochure_VEng_P1-16 spot only.pdf

ApogeeX Brochure_VFr_P1-16 spot only.pdf

ApogeeX Brochure_VGer_P1-16 spot only.pdf

ApogeeX Brochure_LEng_P1-16 spot only.pdf

ApogeeX Brochure_LFr_P1-16 spot only.pdf

ApogeeX Brochure_LGer_P1-16 spot only.pdf

Euro.pdf 
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Contact Us

Agfa welcomes your suggestions, questions or comments about this documenta-
tion. You can send e-mail feedback to: ApogeeX@agfa.com.

About Versioning

The Versioning feature allows you to create jobs which contain several different 
versions, typically for jobs which contain the same background (taken from the 
CMY plates) but have different text for languages or prices (taken from the black 
plate). 

If, for example, you want to publish a brochure in six different languages, you 
can include the Versioning Task Processor in your Production Plan, and then 
print several different language versions of the brochure using a single job. The 
basic Production Plan is straightforward, using a Versioning Task Processor 
instead of a Run List Task Processor. 

This allows you to reduce the number of plates required for the job in an easy and 
manageable way, and to ensure accurate proofing of the plates before commit-
ting them to output.

NOTE: Versioning is an evolution of the Run List. Most of the features and 
behavior of the Run List are present in Versioning.

How to set up a 
versioning job

The standard procedure for setting up a versioning job is as follows:

1 Make an analysis of the version-specific data.

2 Assess how many versions you need to create.

3 Assess which pages are version-specific.

4 Decide how the data is to be delivered. This may be any of the following:

One file containing images and text where the version-specific data is 
added as a separate spot layer.

One common file plus version-specific files

One PDF file using different PDF layers.
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Chf.pdf 

GBP.pdf 

NoPrice.pdf 

Usd.pdf

AXBroch_3Lang.pdf

ApogeeX Brochure_VAus_P16.pdf

ApogeeX Brochure_VCan_P16.pdf

ApogeeX Brochure_VFra_P16.pdf

ApogeeX Brochure_VGerm_P16.pdf

ApogeeX Brochure_VLux_P16.pdf

ApogeeX Brochure_VSwi_P16.pdf

ApogeeX Brochure_VUK_P16.pdf

ApogeeX Brochure_VUsa_P16.pdf

Imposition Layout File

Versioning.pjtf

These files are provided in a single ZIP file, which is available for downloading 
from the Graphics Portal - Services Library website. 

You need to copy the PJTF sample file to the following shared folder on the 
:APOGEE Prepress server:

...\SupportFiles\SampleFiles\PJTF Files.

NOTE: While working through the lessons in this Advanced Tutorial, do not 
forget to replace studentname with your own name in the Administration tab.
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Apogee@agfa.com
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5 Define the version variables:

Only language.

Language plus currency, region, etc.

6 List the expected results.

7 Determine the file names for the different layers.
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LESSON 4: Creating a Versioning Job with PDF Layers

In this lesson, you will create a versioning job from a PDF with layered content.

TIP: In this lesson you will 
use the Auto-fill with PDF 
layers option to create the 
versions.

For these exercises, you will use the AXBroch_3Lang.pdf sample file. The PDF 
file contains four layers:

An images layer (common data)

3 version-specific layers:

English

French

German

Before you start, open the PDF in Adobe Acrobat and look at the layers.

Choose View > Navigation Panels >Layers in Acrobat to see the layers of 
the PDF document and then click the eye icons to hide or show the layers.

(Fully included)
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NOTE: Layers without an “eye” icon are not picked up by :APOGEE Prepress 
because they do not need to be printed.

To create a job ticket for your job

1 From the Jobs window, choose File > Open.

2 Select the studentname-versioning-0004.ajt sample Job Ticket.

3 Click Open.

NOTE: Replace studentname with your own name.

To configure the production plan components

1 Select the Plan tab.

2 Select the Impose component, and unlock the settings.

3 In the Settings pane, make sure that From file is selected in the Imposition 
Selection list.

4 Click the Browse button to the right of the File Selection field.

5 Locate Versioning.pjtf, and click Open.

6 Select the Versioning component.

7 In the Automatic Page Placement panel, make sure that the Place pages 
automatically check box is deselected.

8 Submit the job.

To input a document

1 In the Jobs window, context-click the studentname-versioning-0004 job, 
and select Upload Document from the context menu.

2 Locate and select the following sample file:

AXBroch_3Lang.pdf

3 Click Open.

The document is processed and the pages are ready to be placed in the Page 
Store.

4 Edit the job and in the Plan tab, select the Versioning component and unlock 
the settings.
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5 Click the Versions tab.

No versions have been created yet so this window is empty.

6 Click the cog wheel at the bottom of window and choose Autofill with PDF 
layers.

The Version list is filled and the four layer names of the PDF appear:

English

French

German

Images



Sample

42 CREATING A VERSIONING JOB WITH PDF LAYERS

:APOGEE PREPRESS: Advanced Tutorial doc. version: 6.0.4

NOTE: Layers without an “eye” icon are not picked up by :APOGEE Prepress 
because they do not need to be printed.

To create a job ticket for your job

1 From the Jobs window, choose File > Open.

2 Select the studentname-versioning-0004.ajt sample Job Ticket.

3 Click Open.

NOTE: Replace studentname with your own name.

To configure the production plan components

1 Select the Plan tab.

2 Select the Impose component, and unlock the settings.

3 In the Settings pane, make sure that From file is selected in the Imposition 
Selection list.

4 Click the Browse button to the right of the File Selection field.

5 Locate Versioning.pjtf, and click Open.

6 Select the Versioning component.

7 In the Automatic Page Placement panel, make sure that the Place pages 
automatically check box is deselected.

8 Submit the job.

To input a document

1 In the Jobs window, context-click the studentname-versioning-0004 job, 
and select Upload Document from the context menu.

2 Locate and select the following sample file:

AXBroch_3Lang.pdf

3 Click Open.

The document is processed and the pages are ready to be placed in the Page 
Store.

4 Edit the job and in the Plan tab, select the Versioning component and unlock 
the settings.

 

 VERSIONING 43

doc. version: 6.0.4 :APOGEE PREPRESS: Advanced Tutorial

5 Click the Versions tab.

No versions have been created yet so this window is empty.

6 Click the cog wheel at the bottom of window and choose Autofill with PDF 
layers.

The Version list is filled and the four layer names of the PDF appear:

English

French

German

Images



Sample

44 CREATING A VERSIONING JOB WITH PDF LAYERS

:APOGEE PREPRESS: Advanced Tutorial doc. version: 6.0.4

7 Delete the last version called Images because this is a layer but not a version 
of the printed product.

You now have three versions.

8 Select the Page Assembly tab.

In Page Assembly, the different layers need to be defined.

9 Click the New button to create a layer for the common data.

10 Name the layer Images and leave the Depends on: Version check box 
deselected.

11 In the PDF Layers field, select Images from the drop-down list.

12 Create a second layer for the version-specific data and name it Language 
Text.

13 Select the Depends on: Version check box.

14 In the PDF Layers field, enter the variable <Version>.
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15 Select the Plates tab.

16 Verify the proposed plate delivery.

17 Select the Pages tab.

You will see 1 PDF, and 4 times 16 place holders in the Run List.
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18 Select the PDF in the Page Store.

A pop-up menu is displayed, allowing you to select one of the layers you 
defined earlier.

19 Select the Images layer.

20 Drag the Images layer to the Images column in the Run List.
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21 Next, select all three French, German and English layers together from the 
pop-up list, and drag them to the Run List.

:APOGEE Prepress checks the PDF document layer names against the version 
names used in the setup. When you select multiple layers, it will place only 
those that it recognizes.

22 Submit the job.

23 When the job has been processed, move the cursor over the pages in the Run 
List to see which layers have been placed.
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24 Select the Results tab.

25 Context-click one of the results in the German version, and select View Flat 
From > Latest (PDF Render).

The flat is displayed in Raster Preview.

26 Use the Versions Palette to check the different layers.
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LESSON 5: Versioning with a 5th Plate and DQS

In this lesson, you will create a versioning job from multiple PDFs where version-
specific data is printed on a 5th plate.

TIP: In this lesson you will 
use the Auto-fill with folder 
names option to create the 
versions.

In the sample files, the spot color for the version text is black but designers can 
use any spot color they like. The idea is to separate the black for text from the 
black for images. The spot color is referred to as Versioning_color.

For these exercises, you will use the following sample files:

ApogeeX Brochure_VImages_P1-16.pdf

ApogeeX Brochure_VEng_P1-16 spotonly.pdf in English folder

ApogeeX Brochure_VFr_P1-16 spotonly.pdf in French folder

ApogeeX Brochure_VGer_P1-16 spotonly.pdf in German folder

These PDFs do not have any layers.

Open the Images PDF and for example the German PDF in Acrobat to see the 
data that you will be combining in the exercise.

1 CMYK is taken from the Images PDF for all language versions
2 The German PDF only contains K for text to be printed on a 5th plate

This tutorial is only a preview of the full advanced tutorial.

If you would like to obtain the full version of this tutorial or
a training on this subject, please contact your local Agfa sales

or service representative.
Worldwide addresses of our local Agfa representatives can

be found on our Agfa Graphics website:
http://www.agfagraphics.com/global/en/maings/about_us/

worldwide/index.jsp

http://apogee.agfa.net/contents/KnowledgeBase/Apogee/Prepress/Downloads/Apogee-Advanced-Tutorial/Versioning-in-Apogee-Prepress-Advanced-Tutorial.html
http://www.agfagraphics.com/global/en/maings/about_us/worldwide/index.jsp
http://www.agfagraphics.com/global/en/maings/about_us/worldwide/index.jsp

